Sådan bruger du Excel-funktionen HVIS
i 3 nemme trin

Skrevet af Kasper Langmann, Microsoft Office Specialist.

Ikon til Excel HVIS funktionVil du overlade alt tænke-arbejdet til Excel?

HVIS funktionen gør dine formler i stand til at træffe beslutninger.

Du fodrer HVIS funktionen med et kriterie. Hvis det er overholdt, så sker der noget. Hvis det ikke er overholdt, så sker der noget andet.

På den måde får du dine celler til at tænke, og automatisere dit arbejde.

Lyder det svært?

Bare rolig, det er det ikke.

Denne guide giver dig en grundig indførsel til HVIS – helt fra bunden!

Har du prøvet vores gratis (online) Excel-kursus?
Du lærer 2 andre essentielle funktioner, nemlig SUM.HVIS og LOPSLAG.
Derudover lærer du at bruge det kraftigste rapport-værktøj i verden: Pivottabeller.

Lyder det som noget for dig?
Så klik her og få kurset nu!

*Denne artikel er skrevet i Excel 2019 til Windows, men gælder også for Excel 2010, 2013 og 2016.
Læs alt om Excel 2019/Office 365 og opgrader din Office version her.

Brug HVIS funktionen i 4 nemme trin

Som alle andre funktioner i Excel har HVIS en syntaks.

Syntaksen er et fint ord for hvad du putter ind i funktionen for at få et resultat.

HVIS funktionens syntaks kan du se når du skriver =HVIS( i en celle.

Jeg har oversat den her, så den er lettere at forstå:

Excel HVIS funktion syntaks

Eksempel

I det eksempel jeg tager udgangspunkt i, i denne guide, skal du bruge HVIS funktionen til at angive fragtprisen på visse produkter.

Det er en opgave der tager en evighed at udføre manuelt. Så I stedet for at sidde og udfylde cellerne selv, så lad os opstille nogle regler og lade Excel gøre det tunge arbejde.

Excel HVIS funktion eksempel fragt

Her er scenariet:

Hvis produktnummeret er større end 10.000, så er det en tung genstand, og fragten er 199,-.

Hvis produktnummeret ikke er større end 10.000 (altså er 10.000 eller mindre), så er det en let genstand, og fragten er derfor 99,-.

Nu er det HVIS funktionen der skal læse produktnummeret i kolonne B, og angive enten 199,- eller 99,- i kolonne D.

Lad os komme i gang 🙂

Download denne guides øvelsesfil

Vil du selv prøve kræfter med HVIS funktionen?

Så download den gratis øvelsesfil og gør hvad jeg viser dig i guiden!

Download øvelsesfil
Download øvelsesfil

Trin 1: Kriteriet

Gå til celle D2 og start HVIS funktionen ved at skriv:

=HVIS(

Skriv derefter dit kriterie.

I dette tilfælde er kriteriet at produktet (i celle B2) skal være over 10.000. Det ser sådan her ud:

=HVIS(B2>10000;

Du bruger >, <, >=, <= og = til at skrive dit kriterie i HVIS funktionen. Senere i guiden lærer jeg dig hvordan du bruger de forskellige operatorer!
Kasper Langmann, Partner i Proximo

Trin 2: Handling

Det næste argument i HVIS funktionen er hvad der skal ske hvis kriteriet er overholdt.

Altså, hvis produktnummeret i B2 er over 10.000…

Hvis produktnummeret er over 10.000 ved vi, at fragten er 199,-.

Tallet 199 er derfor det du skal skrive i det andet argument af HVIS funktionen:

=HVIS(B2>10000;199;

Nu mangler du blot et enkelt argument, så er din HVIS funktion færdig.

Trin 3: Anden handling

Det sidste argument i HVIS funktionen er hvad der skal ske hvis kriteriet IKKE er overholdt.

Hvis kriteriet ikke er overholdt, altså hvis produktnummeret IKKE er over 10.000, så må produktet være en let genstand.

Som nævnt tidligere, er fragten for lette genstande 99.

Så, hvis kriteriet ikke er overholdt, skal funktionen returnere tallet 99. Skriv derfor 99 som funktionens sidste argument:

=HVIS(B2>10000;199;99)

Godt gået!

Nu har du lavet en HVIS funktion i 3 trin.

Det var ikke så svært, vel? 🙂

Træk/kopier nu formlen ned til resten af cellerne i kolonne D.

Din funktion skal se sådan her ud nu:

Excel færdig HVIS funktion eksempel

Bonusvideo: Se hvordan jeg bruger HVIS

Forskellige kriterier

Kriterier i HVIS funktionen kommer i forskellige afarter.

I denne sektion lister jeg de vigtigste kriterier, som du kan bruge i dine HVIS funktioner.

Logiske operatorer

Excel har det der i matematikkens verden kaldes “logiske operatorer”, som hjælper dig med at lave forskellige kriterier i Excel generelt.

Dem bruger du når du skriver dit kriterie i det første argument af HVIS funktionen.

Tidligere brugte du kriteriet B2>10000 for at angive, at hvis værdien i celle B2 er større end 10.000, så…

Her er de forskellige logiske operatorer og hvad de gør:

A>B | Hvis A er større end B, så…

A=B | Hvis A er større end eller lig med B, så…

A<=B | Hvis A er mindre end eller lig med B, så…

A=B | Hvis A er lig med B, så…

A<>B | Hvis A ikke er lig med B, så…

Tekst eller tal

Hvis du ikke bruger en reference til at angive dit kriterie (fx. HVIS(A2>B2…), så er det vigtigt du er opmærksom på om dit kriterie er tal eller tekst.

Et tal-kriterie er fx det du brugte tidligere: B2>10000

Et tekst-kriterie kan kun bruge de sidste 2 logiske operatorer. Altså:

A=B | Hvis A er lig med B, så…

A<>B | Hvis A ikke er lig med B, så…

Tekst-kriterier ser typisk sådan ud: =HVIS(A2=”Peter Jakobsen”…

Kasper Langmann, Partner i Proximo

Kombiner HVIS med OG + ELLER

For at udbygge kriteriet kan du tilføje en af de to andre Excel funktioner: OG og ELLER.

Med de to funktioner kan du enten indsnævre kriteriet (med OG) eller udvide kriteriet (med ELLER).

HVIS + OG

Når du kombinerer funktionerne HVIS og OG kan du bruge 2 eller flere kriterier i HVIS funktionen.

OG er en funktion i sig selv, som du putter ind i det første argument (kriteriet) af HVIS.

For eksempel, kan du søge at opnå dette:

“Hvis produktnummeret (kolonne B) er større end 10.000 OG ordrenummeret er mindre end 5170, så er fragten 199. Ellers er fragten 99.”

Ved at kombinere HVIS og OG sådan her:

Excel HVIS + OG funktionerne kombineret

HVIS + ELLER

Når du kombinerer funktionerne HVIS og ELLER kan du også bruge flere end 1 kriterie i din HVIS funktion.

Forskellen er, at OG funktionen gør at der er færre scenarier hvor kriterierne er opfyldt.

ELLER funktionen gør at der er flere scenarier hvor kriterierne er opfyldt.

For eksempel, kan du søge at opnå dette:

“Hvis produktnummeret (kolonne B) er større end 10.000 ELLER ordrenummeret er mindre end 5170, så er fragten 199. Ellers er fragten 99.”

Ved at kombinere HVIS og ELLER sådan her:

Excel HVIS og ELLER funktionen kombineret

Konklusion

Du har nu lært at bruge en af de mest populære (og fleksible) funktioner i Excel.Excel guide konklusion

Godt gået!

Du ved nu, at HVIS blot består af 3 argumenter og kan forklares i denne simple sætning:

“Hvis det her er gældende, så skal der ske det her, hvis ikke, så skal dette andet ske i stedet.”

Derudover har du lært at kombinere HVIS med funktionerne OG og ELLER, hvorved du enten kan slække eller stramme op på dit kriterie.

Andre ressourcer

Princippet bag HVIS funktionen går igen i mange andre Excel funktioner.

Tag for eksempel et kig på SUM.HVIS og TÆL.HVIS som begge udfører specifikke handlinger givet et kriterie.

Indlejrede HVIS funktioner

Er dit scenarie mere komplekst end det jeg har vist dig i denne guide? Så tag et kig på indlejrede HVIS funktioner i Microsofts guide her.

Vil du lære mere?

Kan du fornemme det allerede?

HVIS funktionen bliver din nye bedste ven.

Men HVIS er blot en af flere uundværlige funktioner i Excel.

Tilmeld dig vores gratis online kursus ‘Raffinerede Rapporter og Automatisering’ og lær 2 ligeså vigtige funktioner: SUM.HVIS og LOPSLAG

Derudover lærer du at bruge det kraftigste rapport-værktøj i verden: Pivottabeller

Proximos gratis Excel kursus
Jeg vil prøve jeres gratis kursus
2018-10-13T21:25:44+00:00Microsoft Excel|