Sådan bruger du funktionen TÆL.HVIS i Excel – i 3 trin (COUNTIF)

Skrevet af Kasper Langmann, Microsoft Office Specialist.

TÆL.HVIS og TÆL.HVISER i ExcelSkal du tælle celler i en kolonne, men kun dem der overholder et kriterie?

Fx at tælle hvor mange celler der indeholder et tal over 5000?

Hvor mange celler der indeholder navnet “Birgitte Jensen”?

Eller hvor mange celler der indeholder et tal mellem 10 og 50?

Så er du kommet til det rette sted 😊

I denne guide lærer du at bruge funktionen TÆL.HVIS til alle dine tælle-behov!

*Denne artikel er skrevet i Excel 2019 til Windows, men gælder også for Excel 2010, 2013 og 2016.
Læs alt om Excel 2019/Office 365 og opgrader din Office version her.

Sådan bruger du TÆL.HVIS

Funktionen TÆL tæller alle celler der indeholder tal, og TÆLV tæller alle celler der ikke er tomme.

Hvis du vil skræddersy dit “tælleri” lidt mere, så skal du bruge TÆL.HVIS.

TÆL.HVIS kombinerer to dejlige ting: funktionen TÆL og funktionen HVIS.

Tag et kig på datasættet herunder 👀

Datasæt til TÆL.HVIS eksempel

I kolonne A ser du en masse ordrer, i kolonne B hvem der har solgt dem og i kolonne C hvad prisen var.

Jeg vil tælle hvor mange ordrer der er solgt af sælgeren med initialerne PM og JLA.

Som du kan se på billedet er de allerede talt i celle F2 og F3.

Men hvordan gør jeg det?

Det bliver drøjt hvis jeg gør det manuelt, og TÆL funktionen kan ikke hjælpe mig…

Heldigvis kan TÆL.HVIS gøre det hele for mig på få sekunder.

Og jeg vil nu vise dig hvordan!

Note: Hvis du har den engelske version af Excel så skriv COUNTIF alle de steder jeg skriver TÆL.HVIS.

Vil du selv prøve kræfter med TÆL.HVIS?

Så download vores gratis øvelsesfil, så er du hurtigt og nemt i gang!

Download øvelsesfil
Download øvelsesfil

Følg disse 3 nemme trin for at tælle hvor mange ordrer der er solgt for PM (Peter) og JLA (Josephine).

Trin 1: Syntaks

TÆL.HVIS består af nogle argumenter, som til sammen kaldes funktionens syntaks. Den er heldigvis ganske simpel, og skrives sådan her:

=TÆL.HVIS(område; kriterier)

område = her markerer du hvilket område du vil tælle celler i. Fx hele kolonne B.

kriterier = indtast et kriterie. Hvis du vil tælle celler der er lig med “PM”, så skriver du “PM” her.

Bemærk at funktionen tjekker om kriteriet er overholdt i det område du har angivet i det første argument.

Så marker nu celle F2 (hvis du bruger øvelsesfilen) og indtast:

=TÆL.HVIS(

Start formel med =TÆL.HVIS(

Trin 2: Område

Vælg nu området hvor dit kriterie skal anvendes.

Jeg vil tælle hvor mange celler der indeholder teksten “PM” i kolonne B.

Området er altså = kolonne B.

Skriv:

=TÆL.HVIS(B:B;

Indtast område-argumentet

Har du lagt mærke til at jeg markerer hele kolonnen, B:B, i stedet for kun et område (fx B2:B10)?

Når du markerer en hel kolonne, så er området altid stort nok til hvis der kommer flere rækker med data.

Så prøv at gør det så meget som muligt!

Kasper Langmann, Partner i Proximo

Trin 3: Kriterier

Indtast nu kriteriet for hvad du vil tælle.

Kriteriet anvendes på det område du valgte i trin 2.

Jeg vil tælle hvor mange celler der indeholder teksten “PM” i kolonne B.

Kriteriet er altså = “PM” (inklusive anførselstegn) eller en reference til cellen der indeholder PM.

Skriv:

=TÆL.HVIS(B:B;”PM”)

eller

=TÆL.HVIS(B:B;E2)

Tryk nu på ‘Enter’ og se resultatet i F2, og formlen i formellinjen.

Fuld TÆL.HVIS funktion eksempel

Som du kan se har jeg kopieret formlen i celle F2 ned i F3 også.

Hvis du bruger en reference til celle E2 i kriterie-argumentet, behøver du ikke foretage dig andet for at få formlen til at virke korrekt 🔗

Hvis du har indtastet teksten “PM” som kriterie, skal du gå ind i formlen i F3 og ændre kriteriet til “JLA”.

Og nu har du talt hvor mange ordrer sælgerne Peter (PM) og Josephine (JLA) har solgt!

Smart, ikke?

Du kan bruge mange andre kriterier end det jeg har vist dig her.

For eksempel om et tal er større eller mindre end et andet tal, eller om et tal er mellem to værdier. Læs næste afsnit hvis du vil lære mere om det.

TÆL.HVIS mellem to værdier

Indtil videre har vi kun kigget på hvordan du tæller celler der er lig med noget specifikt.

For eksempel tælle hvor mange celler der er lig med “PM” eller “JLA”.

Det er samme metode du bruger hvis du vil tælle hvor mange celler der er lig med et tal.

Fx hvor mange celler i kolonne C der er lig med 2.280 eller 4.788.

TÆL.HVIS kriterie et lig med et tal

Værdier større/mindre end

Men hvad nu hvis du vil tælle hvor mange celler i kolonne C der indeholder en værdi større end 10.000?

Eller mindre end 6.000?

Så skal du ændre kriteriet lidt.

Kriteriet større end skrives: “>”&tal

Sæt altså anførselstegn omkring større end eller mindre end tegnet, og kombiner det med et tal ved hjælp af &-tegnet.

Dvs. at funktionen til at tælle tal over 10.000 skrives sådan her:

=TÆL.HVIS(C:C; “>”&10000)

Og funktionen til at tælle tal under 6.000 skrives sådan her:

=TÆL.HVIS(C:C; “<“&6000)

Som altid, kan du med fordel bruge referencer i stedet for at skrive tallet direkte ind i funktionen:

=TÆL.HVIS(C:C; “>”&E2)

TÆL.HVIS større end

Større/mindre end eller lig med

Større end og mindre end angives med krokodillenæb (> og <)

Hvis du vil angive at noget er større end eller lig med, så putter du blot et lighedstegn bagefter.

At a er større end eller lig med b skrives altså sådan her:

a >= b

Og at a er mindre end eller lig med b skrives sådan her:

a <= b

At a ikke er lig med b skriver du sådan her:

a <> b

Tal mellem to værdier

For at tælle cellerne der indeholder et tal der ligger mellem 2 værdier, skal du trække 2 TÆL.HVIS funktioner fra hinanden i en formel.

I eksemplet her, vil jeg finde antallet af ordrer hvor prisen er mindre end 10.000 og større end 6000.

Det skrives sådan her:

=TÆL.HVIS(C:C; “<“&10000) – TÆL.HVIS(C:C; “>”&6000)

TÆL.HVIS tal mellem to værdier

Du kan også tælle celler der indeholder tal mellem 2 værdier ved hjælp af den smarte TÆL.HVISER funktion, som blev introduceret i Office365/Excel2019.

Med TÆL.HVISER (på engelsk: COUNTIFS) kan du tælle med flere kriterier.

Læs mere om den her!

Sådan!

Nu har du lært alt om den populære funktion TÆL.HVIS!

Og nu kan du altså tælle celler der overholder et kriterie.

Fx tælle celler der er lig med en tekst, eller celler der indeholder et tal mellem to værdier.

Godt gået 💪

2019-05-29T15:55:47+00:00